Infrastruture issue reported in Finland
Incident Report for BitaBIZ
Resolved
This incident has been resolved.
Posted Dec 12, 2017 - 10:02 CET
Investigating
Time out error related to hosting center ruter.
Posted Dec 12, 2017 - 09:11 CET