SMS not being delivered

Incident Report for BitaBIZ

Resolved

This incident has been resolved
Posted Oct 01, 2018 - 11:32 CEST

Update

We are continuing to work on a fix for this issue.
Posted Oct 01, 2018 - 11:31 CEST

Identified

We are currently experiencing issues with SMS delivery.
Our SMS provider is inspecting the issue.
Posted Oct 01, 2018 - 09:06 CEST
This incident affected: BitaBIZ SMS Delivery.