Exchange / Outlook synchronization (Modern Authentication) fails for some events
Incident Report for BitaBIZ
Resolved
This incident has been resolved.
Posted Apr 17, 2021 - 21:35 CEST
Investigating
We are currently investigating the issue. We will be able to re-synchronize failed events once resolved.
Posted Apr 16, 2021 - 13:05 CEST
This incident affected: BitaBIZ integrations.